Ubiquity EdgeMAX EdgeRouter Lite PPPoE RDS-RCS NAT

So I got a new router to play with .. which looks awesome so far !
Here’s what I did to set up my connection !

configure 
set interfaces eth0 description WAN
set interfaces eth0 pppoe 0 default-route auto
set interfaces eth0 pppoe 0 mtu 1492
set interfaces eth0 pppoe 0 name-server none # you can use 'auto' if you want to use their ns's, I have my own.
set interfaces eth0 pppoe 0 user-id XXXXX
set interfaces eth0 pppoe 0 password XXXXX
set interfaces eth2 description LAN
set interfaces eth2 address 192.168.1.1/24
set firewall options mss-clamp interface-type pppoe
set firewall options mss-clamp mss 1412
set service nat rule 5000 outbound-interface pppoe0
set service nat rule 5000 type masquerade
set system offload ipv4 forwarding enable
set system offload ipv4 pppoe enable # this is the magic word that will offload pppoe from the processor to the ASIC or whatever it is !!!
set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable
set firewall port-forward lan-interface eth2
set firewall port-forward hairpin-nat enable # this will enable machines in the lan to use the wan to connect back to themselves
set firewall port-forward auto-firewall enable
set firewall port-forward rule 1 description apache
set firewall port-forward rule 1 forward-to address 192.168.1.10
set firewall port-forward rule 1 forward-to port 80
set firewall port-forward rule 1 original-port 80
set firewall port-forward rule 1 protocol tcp
set system host-name somehostname.dyn.com # change this
set system name-server 192.168.1.95 # you don't need this if you use auto on the pppoe connection.
set system time-zone Europe/Bucharest
commit
save

3 thoughts on “Ubiquity EdgeMAX EdgeRouter Lite PPPoE RDS-RCS NAT”

  1. Hello!
    Thanks for the above infos. They were very useful to me.
    What about IPv6 on RDS PPPoE ? Have you had any luck ?
    Did you succeed in configuring it ?
    Thnx!

    1. It’s gettin’ to ~ 750M + pppoe overhead. It’s better than anything I’ve ever had ( routers with openwrt ).
      I’m planning on getting a small box with 2 gigabit ports and make it a router.

Leave a Reply

Your email address will not be published. Required fields are marked *